[bookmark: _Toc34657992][bookmark: _Toc34658131][bookmark: _Toc34658261][bookmark: _Toc34658287][bookmark: _Toc34658406][bookmark: _Toc34736831][bookmark: _Toc34737102][bookmark: _Toc34737138][bookmark: _Toc65681594][image: ]Guide to AdLib Cataloguing for Export to the Archives Hub 


Guide to AdLib Cataloguing for Export to the Archives Hub	1
Introduction	1
Setting up your AdLib system	2
The EAD export template (xslt)	2
The EAD export supplement files	3
Export formats	4
Exporting a collection	6
AdLib cataloguing for Hub EAD	8
Settings using Designer	8
Section: Identity statement	10
Section: Conditions of access and use	11
Section: Context	12
Section: Content and structure	13
Section: Allied materials	14
Section: Notes and description control	15
Section: Reproductions	15
Paragraphs	15
Splitting fields	15
Deleting records	15
Components	15
Exporting a multi-level description	16
Uploading to the CIIM	17


[bookmark: _Toc65681595]

Introduction

· The first section is quite technical and describes how to add the export template to your system and add our modified .ada and .bin files. You may want to pass this to your IT support. 
· This guide is intended to assist you with ensuring your AdLib catalogue data is appropriate for contributing to the Archives Hub, as well as outlining the process of exporting.
· The guidance is focused on cataloguing for the export of EAD to create interoperable data, which can be used for the Archives Hub or for other purposes. 
· This is a work in progress.  

NOTE: We have not been able to get all of the data from the Person and Institutions database, but we can take the name and life dates.

The Axiell AdLib help can be found at: http://documentation.axiell.com

[bookmark: _Toc65681596]Setting up your AdLib system

There are two things you need to do in your system in order to export to the Hub.
1. You will need the Archives Hub EAD export template (xslt file) 
2. You will need to add or replace two EAD export supplement files. 

[bookmark: _Toc65681597]The EAD export template (xslt)

In order to provide exports, you will need the EAD export template (xslt file) created by the Archives Hub team.  Check whether you have this already by going to File > Export within the AdLib cataloguing interface and looking at the export options. You will see some AdLib XML export options, and you may also have an EAD option. 
[image: ]



File > Export brings up the list of export options 

In this example there is no EAD export 





[image: ]

Here the Archives Hub EAD export has been added. Check the date of the export file and whether it is the current version. 
 

If you do not have the export file, or need to update it, you can find it at:  https://archiveshub.jisc.ac.uk/adlib/

We make changes to the export template in line with contributor requirements, e.g. adding new fields and enabling multiple entries for fields. If you use an older version of the template, it will still work, but any recent changes that we have made will not be implemented in your export. 

The export template will be called something like adlib-hubead-march2020.xslt.  Copy the file across to the xslt folder in AdLib, e.g. AdLib 4.2 > xslt > adlib-hubead-july2019.xslt

[image: Graphical user interface, application, Teams

Description automatically generated]
AdLib > xslt: you can see a number of .xslt files in this folder – you just need the latest one that we provide

If there is no xslt folder, you need to create one in your AdLib file structure. 

[bookmark: _Toc65681598]The EAD export supplement files

For versions 4.5.2 and later, these files exist within your system, but if you want to export life dates for creators, you will need to replace the ones you have with our modified ones. Unfortunately, this was the only way for us to grab the life dates.  We can take names without dates, but this substantially reduces their utility. 

You need to add, or replace:

· EADexportSupplement.ada
· EADexportSupplement.bin

These will be located in the 'adapls' folder of your AdLib installation folder.

[image: ]
You can see listed in the adapls folder: EADexportSupplement.ada and EADexportSupplement.bin 

The modified files are available from our website: https://archiveshub.jisc.ac.uk/adlib/

Once you have the .xslt export template and the two modified supplementary files, you are ready to export to the Archives Hub. 


[bookmark: _Toc65681599]Setting up the Export 

Open AdLib Designer, go into View > Application Browser, and navigate to the Archives (catalogue) folder (in our system this is in the 'archive' folder) where you should see sections for Methods, Screens, Output jobs and Export formats. 

[image: ] 
AdLib Archive 4.5.1 > archive > AdLib Archive > Archives (catalogue) > Export formats
NB paths may vary from our configuration. 

Under Export formats, you will see the information for your export.  You should have an Archives Hub EAD option, pointing to the EADexportSupplement in adapl.  You should have a path to the Hub xslt, e.g. adlib-hubead-march2020.xslt. If you need to, make changes to create the paths to the Adapl EADexportSupplement and to the Stylesheet (the .xslt template). 

Save the settings if you have made changes using the save (double disk icon) in the top bar. If you cannot save, it may be a permissions issue and you may have to adjust the permissions to give the login you are using full admin rights. 

NOTE: If you do not have an Exports folder, right click from Archives (catalogue) and go to New > Export job

[image: ]

· Name the export 'Archives Hub EAD [date]'. E.g. if you are uploading the March 2020 template, this would be Archives Hub EAD March 2020
· Under Procedure > Adapl navigate to the EADexportSupplement.bin and select it
· Under Stylesheet, change the type to unstructured and add the path to your Hub EAD export xslt
· Under Job title add EAD

Save the settings using the save (double disk icon) in the top bar. 




[bookmark: _Toc65681600]Exporting a collection

To export a collection from the AdLib Archives catalogue you must use the brief display. Search by reference to retrieve a whole collection, e.g. 'BW*' to retrieve BW, BW/ 1, BW/ 2, etc. 

NOTE: If you use different patterns of reference for one collection, this may cause problems with selecting for export. The important thing is to have just the entries for one collection marked for export. E.g. you may have GD1 and GD10 as separate collections – if you search for 'GD1*' you will retrieve both collections. You then need to make sure you only retrieve the collection you want to export – you can do this in the brief display (see below). 

[image: ]
Export of one collection with references all starting 'BW/GG'




[image: ]
Export of one collection – the references are 'JC' and 'J', which is fine as long as these are hierarchically correct and all part of one collection. 



Click on 'All Keys' if you have retrieved the right results. You will then get the 'brief display', showing a list of results with titles and references. 

Click 'Toggle marks' to mark all listed records with a tick. Make sure you have just selected the entries for one collection.

[image: ]

Go to File > Export and select the export type, which should be an Archives Hub EAD option. 
When prompted to save the file, ensure it is exported as XML by adding the .xml file extension.
If you end up with a file called .out (or with any other file extension) it will not render correctly, so adding .xml ensures that it is recognised as an XML file. 

[image: ]
Name the file with an .xml extension


Save the .xml file locally. 

[image: ]                                                                                              n records refers to the count of components




You should get a confirmation message, with the number of entries that have exported (i.e. the number of levels within one collection). 

[image: Graphical user interface, text, application

Description automatically generated]
If you double click to open your saved file it should look something like this – starting with the <?xml> declaration and then displaying the <ead> document. 








[bookmark: _Toc65681601]AdLib cataloguing for Hub EAD

[bookmark: _Toc65681602]Settings using Designer

A number of settings can be made in Designer, which is your tool for selecting fields and behaviours. Note that you need to have access rights for editing in order to change anything in Designer and the interface is not very user friendly. 

When you open Designer you may need to navigate to the AdLib Archive folder first of all, if you have not done this already (you should only need to do this once). Then, when you open the 'Application Browser', you will be in the right location. 

[image: ]

Make sure you have AdLib Archive selected (your view may be slightly different to this, but you should have something similar)





You can then view the Application browser
[image: ]

Selecting the Application browser from the View menu






From the Application browser, you can set up default values for fields.

Entering a default repository value for every record:
· Open the Adlib folder data > collect > Fields > institution.name 
· Go to the Default values tab. 
· Set ‘Type’ to Value and enter the repository name in English. 
· Save your changes. 

You can also add a default repository code, and other defaults. However, it appears that once a default is added, you cannot edit it within the description itself, so only add default values that you don't want to change within the description.  

This is also where you can add values to describe your levels – by going to description_level and adding to the list of values supplied. 

The AdLib site provides more information about default values here: http://documentation.axiell.com/alm/en/index.html?ds_dbfieldspropertiesdefaultvalues.html

Note that changing settings in Designer requires correct permissions. 
[image: ]

NOTE: It is easier to select a field by right-clicking on 'Fields' and using the field list here to sort alphabetically. 

[image: ]
From 'Fields' within the data > collection folder, you can see an alphabetical list. 

NOTE: You should not need to make any changes in Designer – this is just an optional step to allow you to make various configurations and default values. 




[bookmark: _Toc65681603]Section: Identity statement

Repository name and code

It is important to include the repository code (archon code) in your description. In AdLib this is the 'Institution code’ that is accessed through the Persons and Institutions database.  It is preferable to add the archon code without leading zeros, e.g. 17 not 017. 

[image: ]
Persons and institutions database: repository entry with institution code

When you enter the Repository name in your description you should now also see the institution code. 

[image: ]

Do not add the 'GB' to the code. However, if you do have a code included, we should be able to remove it on ingest. 

NOTE: The repository name will be included in your EAD export. However, on the Archives Hub the institution name that we actually display comes from your repository description (EAG file). 

Reference

The reference code field should just contain the reference for the archive. 

[image: ]Identity statement: reference code, title and date span



Title

The title should be a succinct description of the content, without the dates (as these are added separately). 

Dates

Display dates will be exported from the 'Date (free text)' field. These are the dates that the end user sees when they view your description. There are no data requirements for free text dates. 

Normalised dates are dates for searching. They will be created for export if you include 'early' and 'late' dates. Otherwise, our processing will try to add normalised dates for you (it can do this for a variety of date formats, but not for all dates).  
NOTE: AdLib only allows numbers in the date fields, but does not validate for correct date entries, so be careful to enter the values correctly. 

For the Hub, normalised dates that include month and day need to be YYYYMMDD.  

If you do not add normalised dates, the description will export without any problem, but, unless our own processing adds these dates, it will not be included in date filtering within the Hub interface.

[image: ]

Level

It is best to use the drop-down list of level values.  You can go into Designer (Archive/data/collection/Fields), select 'description_level' and go to 'enumeration values' to enter additional values. But the Hub only recognises certain controlled values here. E.g. 'collection' is valid, so you could add this with no problem. 

NOTE: It doesn't appear that AdLib provides for the 'otherlevel' which is supposed to be for additional level values outside of the controlled list If you have used bespoke level values that we do not recognise, we may be able to deal with this in our processing, but it will require a change to the export template.


Other Fields exported from Identity Statement

Extent:  Free text, but we recommend a consistent pattern, e.g.  25 boxes (3 cubic metres)



[bookmark: _Toc65681604]Section: Conditions of access and use 

Language 

Each language should be entered into your AdLib database separately.

[image: ]
This is not the way to include languages. It means that you will have a language called 'English and Latin' and it is not then possible to add an ISO code. All languages should be entered separately and then you can add them to your description. 




To edit languages, Go to the Thesaurus database and pick 'Term'. Search for the language, e.g. 'English' and double click to open it. 

NOTE: You may choose to add the ISO language code for each language you use in the term code field. Be sure to add ISO 639-2 codes (e.g. 'eng' for English).  
Note:  currently there is a bug in some versions of AdLib (4.5.1?) that means the code 'eng' is exported for all languages. You should be fine with version 4.5.2 or later.  If the ISO code is not added, then we will add it during our processing. 

Once you have the database open, you can also add new languages by clicking on 'New' (or Ctrl + N). 

[image: ]
Form for adding a language name and ISO code (term code)

Finding Aids

For the Archives Hub, it can be useful to link to your AdLib catalogue, but that would mean putting the URL for your AdLib catalogue in this field. So, if this field displays in your AdLib front end, then the catalogue will link to itself, but the Archives Hub will also link directly to it.   

Other fields exported from Conditions of access and use

Conditions governing access: free text
Conditions governing reproduction: free text
Physical characteristics: free text


[bookmark: _Toc65681605]Section: Context

Creator Name

The creator name is taken from a separate Persons and Institutions database. As long as it displays in the AdLib catalogue it will export. 

NOTE: The creator name usually comes with a type="creator", but we have no way of knowing if the creator is a person or organisation. 

[image: ]
The export will not explicitly state that the agent is a person, organisation or family. 



You can include an additional name type by using the 'Add occurrence' option in the menu bar. 

[image: ]
Here, the name has the type 'author' and the type 'person'. 







Life dates should be added in order to properly identify a person. They are in the 'Description' tab.


[image: ]
Add birth and death dates to ensure that you have a structured name entry, and the person is unambiguously identified. 



Ideally life dates should be added in the dates fields. Alternatively you can add them directly into the authorised name, but note that if you add them in both places, the life dates may be added twice.

Prefix(es) to surname will export, e.g. 'Sir', 'Lady'. 

Additions to name will export, so you can add an epithet here. However, Adlib creates an order that displays additions to a name before the life dates. E.g. Atkins, Nancy (writer and broadcaster) (1880 - 1953). This means that on balance it might be better to avoid adding the additional information.

NOTE:  the creator name will not appear as an index term automatically, you have to add it from within AdLib. We strongly recommend doing this, otherwise a name search on the Hub may exclude the name of creator, because AdLib creator name does not identify the creator as a person or organisation, whereas index terms do. 

Biographical History

Add the biographical or administrative history to the 'Other information > History/Biography' field in the Description tab within the persons/organisations database in order that it can be exported.  


[bookmark: _Toc65681606]Section: Content and structure

Scope and Content

Enter your scope and content, including significant names, places and events.  If you add new lines these will become new paragraphs within the Archives Hub display. 

Index terms: Person/Institution
Add people and institutions in the Content and structure tab to create index terms. All the names added need to be put into the Persons/Institutions list. This is separate to the Creator names list, so you need to add the creator(s) again as an index term. When you double click within the archives catalogue record you can see a quick view of the table. It shows whether there are life dates.

[image: ]
The content.person.name table – check for life dates here. 

Index terms: Subjects

Subjects can be added as term type: subject within the Thesaurus under Terms. They are added to the catalogue as Subject type: subject.  We recommend using recognised thesauri, and you can add the source in AdLib, but it won't currently export to the Hub. 

Index terms: Place Names

Place names can be added as term type: geographical keyword within the Thesaurus under Terms. They are added to the catalogue record as Subject type: geography.

The 'broader term' should also export, but it appears that you can only have one broader term, e.g. Brighton, East Sussex, or Ramsbottom, England.  It is not good practice to simply put Brighton, as there are places called Brighton all over the world, so always use a qualifier. 

Other Fields exported from Content and Structure

Appraisal: free text
Accruals: free text
System of arrangement: free text


[bookmark: _Toc65681607]Section: Allied materials

Digital Objects

You can export digital objects from the 'Digital references' section. You need to have an accessible URL for your image, with an optional description. Ensure you enter the full URL with the http(s).  You can add more than one digital reference.  

[image: ]

Other Fields exported from Allied Materials

Existence of originals: free text
Existence of copies: free text
Related units of description notes (not related object information) : free text
Publication note: free text


[bookmark: _Toc65681608]Section: Notes and description control

Notes within the 'Notes and description control' area are exported as 'note' in EAD, so they will be displayed under our Notes label.


[bookmark: _Toc65681609]Section: Reproductions

Reproduction references will export as digital objects, and notes can be added to these. You can also add digital objects under Allied Materials. 


[bookmark: _Toc65681610]Paragraphs

If you start text on a new line in AdLib, this will create a new paragraph on the Archives Hub.

[image: ]
A new line will export as a separate paragraph


[bookmark: _Toc65681611]Splitting fields

If you want to enter more than one value in a structured field, e.g. creator or language, then add an occurrence of the field (Ctrl + Enter adds an occurrence immediately below the field holding the cursor). If you try to add a language that is not in the language database, you will be prompted to add it. 

NOTE: We have had a number of contributors adding a language such as 'English, French and some German'. This is not a good idea, as it is not structured text, and it will not validate. Always add a field for each new language. 


[bookmark: _Toc65681612]Deleting records

It seems best to delete records within a hierarchical collection by using the 'Brief display', which is the hit list where you can select records. You can then delete the current record, or all marked records.  To get the brief display you may need to ensure you have 'include narrower keys' ticked. 


[bookmark: _Toc65681613]Components

Right-click in the hierarchy browser to bring up a menu. This includes the option to 'insert'. Click insert in order to bring up a new blank form. Enter the details, e.g. a series entry using slashes to indicate the hierarchy in the reference code. You need reference and title as minimum in order to save, but it is also helpful to add level, as this is displayed in the hierarchy browser. 

[image: ]

The hierarchy browsers shows the reference / level / title (slashes indicate divisions). 

Alternatively, you can add a batch of child records using the 'Add child records' option. This creates your required number of blank entries, showing / / in the hierarchy, ready to add reference, level and title. 


[bookmark: _Toc65681614]Exporting a multi-level description

You need to be on the brief description view, not the catalogue view. Make sure you have your complete description, so search for your reference (or use another search that retrieves the whole catalogue). 

[image: ]
Preparing to export the JC collection with components

Ensure all the entries are ticked (Mark record/Toggle marks).  Go to File > Export and select the Archives Hub EAD export. Browse for a destination, name your record, using the .xml file type and click Finish to execute the export. You should get a confirmation message. 

[image: ]

You can view the record on your machine simply by opening your file explorer and clicking on the record to open it.

[image: ]
 

You should see an EAD record, with the requisite tags.  Don't worry that the <eadid> shows 'xxx' content. This is something the Archives Hub can populate when we process the description.  We do a number of things to normalise and standardise descriptions when they are loaded into our system. 


[bookmark: _Toc65681615]Uploading to the CIIM

For more detailed information on using the CIIM, please see the CIIM guide and video tutorials: https://archiveshub.jisc.ac.uk/ciim/

NOTE: We need to confirm that you are exporting from AdLib, so that we can set up the AdLib processing pipeline for your files.  Don't upload to the CIIM until you know that we have set up your pipeline. 

Once you have exported your .xml file, you can log into the CIIM, go to the Data Manager tab and use the upload facility.
[image: ]

Upload your exported .xml file to the CIIM




If you get errors once the file has uploaded, refer to the CIIM guides or email the Hub contributors' helpdesk, contributors.hub@jisc.ac.uk. 
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